Sparked Host LLC - Network Instability Due to Upstream DDoS Events (Cosmic Guard) – Incident details

Experiencing partially degraded performance

Network Instability Due to Upstream DDoS Events (Cosmic Guard)

Identified
Degraded performance
Started 2 days ago

Affected

Locations

Degraded performance from 5:57 PM to 12:00 AM

Dallas

Degraded performance from 5:57 PM to 12:00 AM

Ashburn

Degraded performance from 5:57 PM to 12:00 AM

Updates
  • Identified
    Identified

    Cosmic has implemented a fix for this on their side and is monitoring the situation. We will let you know if we notice any further drops.

  • Investigating
    Investigating

    We are currently seeing network instability impacting some customers, due to our upstream DDoS mitigation provider Cosmic Guard experiencing extremely large-scale DDoS attacks targeting their edge infrastructure.

    These attacks are not directed at our network specifically, but due to their scale, they are causing intermittent latency, packet loss, or route flapping for some customers depending on region and path.

    We are actively monitoring the situation and are in communication with Cosmic Guard to assess mitigation progress and possible workarounds.

    As always, we are committed to network stability and will post updates as we receive more information.